summaryrefslogtreecommitdiff
path: root/dev-ruby/journey/journey-1.0.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/journey/journey-1.0.4-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/journey/journey-1.0.4-r1.ebuild')
-rw-r--r--dev-ruby/journey/journey-1.0.4-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/journey/journey-1.0.4-r1.ebuild b/dev-ruby/journey/journey-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..b83661d7fbcb
--- /dev/null
+++ b/dev-ruby/journey/journey-1.0.4-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Journey is a router. It routes requests"
+HOMEPAGE="https://github.com/rails/journey"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/hoe
+ dev-ruby/json
+ dev-ruby/minitest )"
+
+RUBY_PATCHES=( "${FILESDIR}"/${P}-fix-tests.patch )