summaryrefslogtreecommitdiff
path: root/dev-ruby/jmespath/jmespath-1.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-ruby/jmespath/jmespath-1.6.0.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-ruby/jmespath/jmespath-1.6.0.ebuild')
-rw-r--r--dev-ruby/jmespath/jmespath-1.6.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/jmespath/jmespath-1.6.0.ebuild b/dev-ruby/jmespath/jmespath-1.6.0.ebuild
new file mode 100644
index 000000000000..b640b015b668
--- /dev/null
+++ b/dev-ruby/jmespath/jmespath-1.6.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_GEMSPEC="jmespath.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements JMESPath for Ruby"
+HOMEPAGE="https://github.com/jmespath/jmespath.rb"
+SRC_URI="https://github.com/jmespath/jmespath.rb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}.rb-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~arm64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' \
+ spec/{compliance_spec,compliance_without_errors_spec,spec_helper}.rb || die
+ sed -i -e '/bundler/I s:^:#:' spec/spec_helper.rb || die
+}