summaryrefslogtreecommitdiff
path: root/dev-ruby/irb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-08 12:03:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-08 12:03:01 +0100
commit522fa4e6f267ba688a264ceec8d6c79663b61219 (patch)
tree67895f3a8243148309fbd841dabba28c37f4ed4a /dev-ruby/irb
parent32c16465e56b0122cf6e5a4625e9c7b56b107b07 (diff)
gentoo auto-resync : 08:10:2023 - 12:03:01
Diffstat (limited to 'dev-ruby/irb')
-rw-r--r--dev-ruby/irb/Manifest3
-rw-r--r--dev-ruby/irb/irb-1.7.4.ebuild53
-rw-r--r--dev-ruby/irb/metadata.xml11
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-ruby/irb/Manifest b/dev-ruby/irb/Manifest
new file mode 100644
index 000000000000..06ef6991ee60
--- /dev/null
+++ b/dev-ruby/irb/Manifest
@@ -0,0 +1,3 @@
+DIST irb-1.7.4.tar.gz 115221 BLAKE2B 8905dbad13363fff33ae719258673d1818e3eb7dfd508254d3f2bbb28e315be2fe15614ea63cef7718a2da4a7c4ef99dc9bc76d270b5219203751dc06a7161de SHA512 562ca1deb78223f6b0b9534d9d1756d8eaffe8dfb7f550238a4afabfb42622109716ccabdef805d8aa2c14dbb73abad8a32c0261c04064281216d40bc57b87ad
+EBUILD irb-1.7.4.ebuild 1416 BLAKE2B 46298c730b0fb2b51365cf1efca8161a12d4d2517542c14a1fcb1ba655729a46e249f07251e92ac08bea751c63c6fa4f92014e17330e95c7903ba66a25ae2f93 SHA512 61817625f5219c96375534fd54e4f19bebf3e1fe2d73f49ab1d79bca9bc3f182c4811aee0f8089ff81c113f4f9af8176ed67261a2a5db6df2f64f64d2a1e900d
+MISC metadata.xml 335 BLAKE2B 6eaf8bbdf5e2083121d0c8833b616e8ccfd82715cb701266d9e1819634ccbe1e308bac8a1894559af941810c84f36c5cbc83f1aa02f48ab5ab3d0d3458fc6b85 SHA512 4240cfcb50e6d5551333400723b3ad0df9096a3b5517655279de6b3d31c6f30068e4897c79761fdbb68262681a79059349e1b4eb3f5d1e6b1855dfb6b6d54399
diff --git a/dev-ruby/irb/irb-1.7.4.ebuild b/dev-ruby/irb/irb-1.7.4.ebuild
new file mode 100644
index 000000000000..9fe1c976ddcc
--- /dev/null
+++ b/dev-ruby/irb/irb-1.7.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_BINDIR="exe"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="irb.gemspec"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Interactive Ruby command-line tool for REPL (Read Eval Print Loop)"
+HOMEPAGE="https://github.com/ruby/irb"
+SRC_URI="https://github.com/ruby/irb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE=""
+
+# Ensure a new enough eselect-ruby is present to avoid clobbering the
+# irb bin and man page.
+ruby_add_rdepend "
+ >=dev-ruby/rdoc-6.5:0
+ >=dev-ruby/reline-0.3.6
+ !<app-eselect/eselect-ruby-20231008
+"
+
+ruby_add_bdepend "test? ( dev-ruby/bundler )"
+
+all_ruby_prepare() {
+ sed -e 's:_relative ":"./:' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Skip test requiring specific character set
+ sed -e '/test_raise_exception_with_different_encoding_containing_invalid_byte_sequence/aomit "charset"' \
+ -i test/irb/test_raise_no_backtrace_exception.rb || die
+
+ # Skip tests requiring a working console
+ rm -f test/irb/test_debug_cmd.rb || die
+}
+
+each_ruby_test() {
+ RUBYLIB=lib ${RUBY} -S rake test || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/irb.1
+}
diff --git a/dev-ruby/irb/metadata.xml b/dev-ruby/irb/metadata.xml
new file mode 100644
index 000000000000..860a8cf3bc11
--- /dev/null
+++ b/dev-ruby/irb/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby/irb</remote-id>
+ </upstream>
+</pkgmetadata>