summaryrefslogtreecommitdiff
path: root/dev-ruby/io-console
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-01 13:45:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-01 13:45:28 +0100
commit676f73d9e2fbb9f03291bae80529ba45f541d3c8 (patch)
tree4dae0ba3eea1b25e109d944bde85f44e763c6441 /dev-ruby/io-console
parent910ec713340312b0b8437a7307c8effaa33fb410 (diff)
gentoo auto-resync : 01:07:2023 - 13:45:28
Diffstat (limited to 'dev-ruby/io-console')
-rw-r--r--dev-ruby/io-console/Manifest3
-rw-r--r--dev-ruby/io-console/io-console-0.6.0.ebuild36
-rw-r--r--dev-ruby/io-console/metadata.xml11
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-ruby/io-console/Manifest b/dev-ruby/io-console/Manifest
new file mode 100644
index 000000000000..941e444951b4
--- /dev/null
+++ b/dev-ruby/io-console/Manifest
@@ -0,0 +1,3 @@
+DIST io-console-0.6.0.tar.gz 45358 BLAKE2B 0de9eabbc2dd218e7ff367d970133080eda36178f35655c392ba6ab73866cb7fba09fd26a16062ef1f1bab1fb941486f13e277589aa98954612d4593421afcff SHA512 25e6fc318c51dc9f8daf5743340505eea7c5364b1787862464bfb45afb99c7c7ac8c55caf1f53c5fb5921269f3827262f17449f110efbcc44f7364235563959d
+EBUILD io-console-0.6.0.ebuild 1176 BLAKE2B 14089b18748c70bbf5d5049061491256a81cd18a767b6a22539a154b871bab72c13ff59b74da3f55f0572e45c54c471ecc094faf8d740d9ef6158f72230adee8 SHA512 9c205b580d4530dc3d0befe23fcbafcecdf2000133afb906c33410dbd4c9ea94a75c78f3084a02a5de450b38e7e919ba9f52bc59cbf393a6f6a1dcfff8bd1a82
+MISC metadata.xml 342 BLAKE2B 8fd9851a96fd893fd5a6163369d04bf07accc93912f989a39b8fdb0c1aab73c1df0acfb1a565b75ba617629c07bf61589f7e77b64feb16dc3e1138bcda663788 SHA512 58bc013a81541638df5e9891cb587ab49ae06dbe14f221b5f1871f518e7d90a81869a625b7e49e4e62b7d55dfee5d3c607e93de3abb4588d276d26e22ef4622a
diff --git a/dev-ruby/io-console/io-console-0.6.0.ebuild b/dev-ruby/io-console/io-console-0.6.0.ebuild
new file mode 100644
index 000000000000..6c1240d7498a
--- /dev/null
+++ b/dev-ruby/io-console/io-console-0.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/io/console/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR="lib/io"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="io-console.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="add console capabilities to IO instances"
+HOMEPAGE="https://github.com/ruby/io-console"
+SRC_URI="https://github.com/ruby/io-console/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -e '/task :test/ s:^:#:' -i Rakefile || die
+
+ # Avoid test that require a proper TTY
+ sed -e '/test_\(bad_keyword\|failed_path\)/aomit "requires TTY"' \
+ -i test/io/console/test_io_console.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test:test/lib -rhelper -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}
diff --git a/dev-ruby/io-console/metadata.xml b/dev-ruby/io-console/metadata.xml
new file mode 100644
index 000000000000..e316e22be118
--- /dev/null
+++ b/dev-ruby/io-console/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby/io-console</remote-id>
+ </upstream>
+</pkgmetadata>