summaryrefslogtreecommitdiff
path: root/dev-ruby/instantiator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/instantiator
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/instantiator')
-rw-r--r--dev-ruby/instantiator/Manifest5
-rw-r--r--dev-ruby/instantiator/instantiator-0.0.6.ebuild25
-rw-r--r--dev-ruby/instantiator/instantiator-0.0.7.ebuild25
-rw-r--r--dev-ruby/instantiator/metadata.xml11
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-ruby/instantiator/Manifest b/dev-ruby/instantiator/Manifest
new file mode 100644
index 000000000000..d0038a75be61
--- /dev/null
+++ b/dev-ruby/instantiator/Manifest
@@ -0,0 +1,5 @@
+DIST instantiator-0.0.6.gem 6144 BLAKE2B 6add4d12cce98be209ac3d1073c17163c10c6c015eb40c9d8efcf3c4521e56c736618d11c4a06f52a0d16ffdf2b6815fb6e04ce823fc79febf997dec30aa1904 SHA512 0d24c804dd048c071e5ddd021a1adcb907eb642df16ce841fdca2efdfd5604f73d065ad4496cf6d63bdff73e7488391d7226bdc0d918d2813502ca3d4fc615a1
+DIST instantiator-0.0.7.gem 8192 BLAKE2B c1cc0bf4a3f2aaf9afd522e33fdd2b32d78ca114fc7b113f6ae297e825177827cb6aa5398917d6d05523f912bebf22e43709e53c0dfe4e1a941ebda4350d3098 SHA512 b37a9380d787252244d2b85bb99365f4a4ecdab58f76caf5e59df00b239f4981119eb5c2eb2fe6ddcf810bb0fb43695f8926370a101f4223fa28811953e6731d
+EBUILD instantiator-0.0.6.ebuild 572 BLAKE2B fa02578109dd6b75d2b729c55d1c5b1210b9e1467fb1460326177889b7e40f68e36dc7c09dc77469e3893ce9d160c09ec7e35adfde71a8d0f0ce1f5674f38f94 SHA512 e93542390c4e270377f28d9fa59a33d21396f3137128d23ffe909035e8adb6933e84342a1d8efe9c99703e26be1daf0e29c6ad1b63cdae0ed30ea6d7e7625284
+EBUILD instantiator-0.0.7.ebuild 567 BLAKE2B 1cfd7311dd0f302254625ec9390d15e308e8397406a0d9320ad6fcc9b7829ebfac4237a0608c715bc57019aaba7e36661b80827b83cc70f706f676bdfc8433b4 SHA512 3ec6d4549724dc46b712ef3e560624b014a3f4d90c9efcdd9976f4d11853093346a7f1d8e2a7530da28cb9380d2aa5ca1273e76e34a5d8947a0ce3bb4239bf55
+MISC metadata.xml 350 BLAKE2B 3a675060e310b02ef2d6408b7b7114651555ae65ed76f6311947a7c6b01e18c638775ae71c504892845b5f9fde2bf5560c3e267fa478bc105c3732a2ee821fc8 SHA512 48661d17e8297087c541040534f2c19ef983be797cd9feb5a9e7d80f8bfcfba027e8c2e42d8625a0a0f76bc60247372b2ae0f984b6ae8f635f28bac33156fe1d
diff --git a/dev-ruby/instantiator/instantiator-0.0.6.ebuild b/dev-ruby/instantiator/instantiator-0.0.6.ebuild
new file mode 100644
index 000000000000..baa1842e7f0c
--- /dev/null
+++ b/dev-ruby/instantiator/instantiator-0.0.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Instantiate an arbitrary Ruby class"
+HOMEPAGE="https://github.com/floehopper/introspection"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sparc x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/blankslate:*"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile test/test_helper.rb || die
+}
diff --git a/dev-ruby/instantiator/instantiator-0.0.7.ebuild b/dev-ruby/instantiator/instantiator-0.0.7.ebuild
new file mode 100644
index 000000000000..e9b004c8f8fb
--- /dev/null
+++ b/dev-ruby/instantiator/instantiator-0.0.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Instantiate an arbitrary Ruby class"
+HOMEPAGE="https://github.com/floehopper/introspection"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~hppa ia64 ~ppc ppc64 ~sparc x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/blankslate:*"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile test/test_helper.rb || die
+}
diff --git a/dev-ruby/instantiator/metadata.xml b/dev-ruby/instantiator/metadata.xml
new file mode 100644
index 000000000000..6bdfd4e13513
--- /dev/null
+++ b/dev-ruby/instantiator/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">floehopper/introspection</remote-id>
+ </upstream>
+</pkgmetadata>