summaryrefslogtreecommitdiff
path: root/dev-ruby/instantiator/instantiator-0.0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/instantiator/instantiator-0.0.7.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/instantiator/instantiator-0.0.7.ebuild')
-rw-r--r--dev-ruby/instantiator/instantiator-0.0.7.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/instantiator/instantiator-0.0.7.ebuild b/dev-ruby/instantiator/instantiator-0.0.7.ebuild
new file mode 100644
index 000000000000..e9b004c8f8fb
--- /dev/null
+++ b/dev-ruby/instantiator/instantiator-0.0.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Instantiate an arbitrary Ruby class"
+HOMEPAGE="https://github.com/floehopper/introspection"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~hppa ia64 ~ppc ppc64 ~sparc x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/blankslate:*"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile test/test_helper.rb || die
+}