summaryrefslogtreecommitdiff
path: root/dev-ruby/image_processing/image_processing-1.12.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-10 22:36:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-10 22:36:46 +0100
commit783da4542a9c3e0e1ec703644212707cde610679 (patch)
tree3e0cf56ac37ddf9d5fdc6ff0ced9135b1c7fc5e0 /dev-ruby/image_processing/image_processing-1.12.2.ebuild
parentd0041c590ed45bbfeae458ea926e36bc64e41dd7 (diff)
gentoo auto-resync : 10:09:2023 - 22:36:45
Diffstat (limited to 'dev-ruby/image_processing/image_processing-1.12.2.ebuild')
-rw-r--r--dev-ruby/image_processing/image_processing-1.12.2.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-ruby/image_processing/image_processing-1.12.2.ebuild b/dev-ruby/image_processing/image_processing-1.12.2.ebuild
index 8442915b178d..0e84e582aef1 100644
--- a/dev-ruby/image_processing/image_processing-1.12.2.ebuild
+++ b/dev-ruby/image_processing/image_processing-1.12.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+USE_RUBY="ruby30 ruby31 ruby32"
RUBY_FAKEGEM_RECIPE_DOC="none"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md doc/*.md"
@@ -42,4 +42,7 @@ all_ruby_prepare() {
sed -i -e '/\(assert\|refute\)_similar/ s:^:#:' test/*_test.rb || die
sed -i -e '/\(bundler\|phashion\|vips\)/ s:^:#:' Rakefile test/test_helper.rb || die
+
+ # Fix minitest deprecation
+ sed -i -e 's/MiniTest/Minitest/' test/test_helper.rb || die
}