summaryrefslogtreecommitdiff
path: root/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-28 15:04:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-28 15:04:41 +0100
commite74494cd71c90a42f7cf78ec655c9c883a26c42a (patch)
tree06c91f279ebdf8ba4dcdab90385d7fb04a4d0e27 /dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r2.ebuild
parent35e8572a0d6310d3eac4be1600ef2de6cb6881ab (diff)
gentoo auto-resync : 28:07:2022 - 15:04:40
Diffstat (limited to 'dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r2.ebuild')
-rw-r--r--dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r2.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r2.ebuild b/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r2.ebuild
index 26c7f9681990..c8083353aa1e 100644
--- a/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r2.ebuild
+++ b/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27"
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="README.md"
@@ -22,3 +22,8 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc x86"
IUSE=""
+
+all_ruby_prepare() {
+ # rspec 3 compatibility
+ sed -i -e 's/be_true/be true/; s/be_false/be false/' spec/parser_spec.rb || die
+}