summaryrefslogtreecommitdiff
path: root/dev-ruby/http/http-3.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-15 02:11:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-15 02:11:33 +0100
commit0fdd4074ff3dc0c507a9867380a4f91250a0b610 (patch)
tree83d3b64438d2f29b375d895f12b82d5c484db219 /dev-ruby/http/http-3.0.0.ebuild
parent8fbd420dce8836e6503b162092e07b6a77a89f1d (diff)
gentoo resync : 15.10.2017
Diffstat (limited to 'dev-ruby/http/http-3.0.0.ebuild')
-rw-r--r--dev-ruby/http/http-3.0.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/http/http-3.0.0.ebuild b/dev-ruby/http/http-3.0.0.ebuild
new file mode 100644
index 000000000000..06a9349cf240
--- /dev/null
+++ b/dev-ruby/http/http-3.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy-to-use client library for making requests from Ruby"
+HOMEPAGE="https://github.com/tarcieri/http"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~ppc64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/addressable-2.3
+ >=dev-ruby/http-cookie-1.0
+ >=dev-ruby/http-form_data-1.0.1:1.0
+ >=dev-ruby/http_parser_rb-0.6.0 =dev-ruby/http_parser_rb-0.6*"
+
+ruby_add_bdepend "
+ test? ( dev-ruby/certificate_authority dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/end/ s:^:#:' \
+ -e '1irequire "cgi"' spec/spec_helper.rb || die
+
+ # Avoid specs that require network access
+ sed -i -e '/.persistent/,/^ end/ s:^:#:' \
+ spec/lib/http_spec.rb || die
+ sed -i -e '/with non-ASCII URLs/,/^ end/ s:^:#:' \
+ spec/lib/http/client_spec.rb || die
+
+ # Avoid spec that may fail with a running web server
+ sed -i -e '/unifies socket errors into HTTP::ConnectionError/,/^ end/ s:^:#:' spec/lib/http_spec.rb || die
+}