summaryrefslogtreecommitdiff
path: root/dev-ruby/http-form_data/http-form_data-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-12 17:23:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-12 17:23:15 +0100
commit6e0dec7ba4f6c5793a3d0b85952efa7ec57afa65 (patch)
treedcf170f6adae0db9a35f68683c81d68edfc54158 /dev-ruby/http-form_data/http-form_data-2.0.0.ebuild
parentab58e299fd6dae92ea274fe7d0ad685d888a51b7 (diff)
gentoo resync : 12.10.2017
Diffstat (limited to 'dev-ruby/http-form_data/http-form_data-2.0.0.ebuild')
-rw-r--r--dev-ruby/http-form_data/http-form_data-2.0.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/http-form_data/http-form_data-2.0.0.ebuild b/dev-ruby/http-form_data/http-form_data-2.0.0.ebuild
new file mode 100644
index 000000000000..41f84b29b64a
--- /dev/null
+++ b/dev-ruby/http-form_data/http-form_data-2.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility-belt to build form data request bodies"
+HOMEPAGE="https://github.com/httprb/form_data.rb"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/SimpleCov.start/ s:^:#:' spec/spec_helper.rb || die
+}