summaryrefslogtreecommitdiff
path: root/dev-ruby/http-accept/http-accept-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /dev-ruby/http-accept/http-accept-2.1.0.ebuild
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'dev-ruby/http-accept/http-accept-2.1.0.ebuild')
-rw-r--r--dev-ruby/http-accept/http-accept-2.1.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/http-accept/http-accept-2.1.0.ebuild b/dev-ruby/http-accept/http-accept-2.1.0.ebuild
new file mode 100644
index 000000000000..96888b18982e
--- /dev/null
+++ b/dev-ruby/http-accept/http-accept-2.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Parse Accept and Accept-Language HTTP headers"
+HOMEPAGE="https://github.com/socketry/http-accept"
+SRC_URI="https://github.com/socketry/http-accept/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/covered/ s:^:#:' spec/spec_helper.rb || die
+}