summaryrefslogtreecommitdiff
path: root/dev-ruby/hpricot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /dev-ruby/hpricot
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'dev-ruby/hpricot')
-rw-r--r--dev-ruby/hpricot/Manifest1
-rw-r--r--dev-ruby/hpricot/hpricot-0.8.6-r6.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-ruby/hpricot/Manifest b/dev-ruby/hpricot/Manifest
index 9ec5baaca3b2..bc9bf58aeb40 100644
--- a/dev-ruby/hpricot/Manifest
+++ b/dev-ruby/hpricot/Manifest
@@ -1,4 +1,5 @@
AUX hpricot-0.8.6-fast_xs.patch 650 BLAKE2B 5ad93195325fa1e26c2d207fefec83c8e01bbcbfdf933e6925a10bcf74a56c94b8517c7000a3c1aecff091b4d5d1cb3c29c9c899af7a5a5f5f0a17b1967118da SHA512 cbb1aa6138ec98e2eac9bcad8d06ed7c435a8ca503e062776576cfdddb944b294b270dd30e2c2924441ea527445df149e7ce34d085652ca6f184c4e66d209b8d
DIST hpricot-0.8.6.gem 293888 BLAKE2B 5c054c6fcd5c3365dbf44f3c502bc4c1c3885f4aa43fd1fd15365aea19600ef0ef48157c39ef1709386bda0bc3fb6bba6d98862e8e28bdb5c173429969ef5ab9 SHA512 f0ea9168ae79d099cdb751dd5a205e0896dfb229759e499fff833e94209d1497aa97becb285176dcbcc1fee19bc11913ca3ac0d7a467067e5d837c1eb6e310ad
EBUILD hpricot-0.8.6-r5.ebuild 1657 BLAKE2B cc952f3491113ec1bb392cca66fc3c42dec0d6cb83ddd52fc9101b1ece2e8c4a68b7c57d13487400c68ed466f3dea663d210be40d03e28781819891827c7c37b SHA512 7ce07fa04e050fb247833c2dfd3cb25298475c1bddf93ae86cf4fdd0087cd7c090e22f1d6d3dddfdd5f34a58be99577a2451ccafbe869312f1ca9491fdce6a69
+EBUILD hpricot-0.8.6-r6.ebuild 1464 BLAKE2B ab680367186182620438c5b97d8663a11acf9ce0c4de950fc158a72174d1689403a8484774dbfb2e5d6662b82618a17c1695c7c7ed02808c56a831b117c9d6b6 SHA512 f071de018cb8c094d0c7a142a35365fdfd9ab86406956e1f617442eacde5a051109448ec240c0cc0e302bf4ecc89033eac854d5849b77aea14b6c8c8a7f6185f
MISC metadata.xml 247 BLAKE2B 7717702c51c35b2a20983332abc6218047b2b5036e6b4c09d3d58b4339e8f9e776879cd116cfda60d3bcf4188859993fb9f3f779aaf595f155d53e85288f3dcc SHA512 ea4c044637b751a2c28c6ac226121e74ef18196af4b594e60413fec907bbab29c6b0c7735c3f503485df16dcfb36ddb86038394d92e2cd18c8f04626628e9f09
diff --git a/dev-ruby/hpricot/hpricot-0.8.6-r6.ebuild b/dev-ruby/hpricot/hpricot-0.8.6-r6.ebuild
new file mode 100644
index 000000000000..4af8d4a90b3c
--- /dev/null
+++ b/dev-ruby/hpricot/hpricot-0.8.6-r6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/hpricot_scan/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="A fast and liberal HTML parser for Ruby"
+HOMEPAGE="https://wiki.github.com/hpricot/hpricot"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "dev-ruby/rake
+ dev-ruby/rdoc
+ dev-ruby/rake-compiler"
+
+ruby_add_rdepend "dev-ruby/fast_xs"
+
+# Probably needs the same jdk as JRuby but I'm not sure how to express
+# that just yet.
+DEPEND+=" dev-util/ragel"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+
+ # Fix encoding assumption of environment for Ruby 1.9.
+ # https://github.com/hpricot/hpricot/issues/52
+ # sed -i -e '1 iEncoding.default_external=Encoding::UTF_8 if RUBY_VERSION =~ /1.9/' test/load_files.rb || die
+
+ # Avoid unneeded dependency on git.
+ sed -i -e '/^REV/ s/.*/REV = "6"/' Rakefile || die
+
+ # Fix int size warning
+ sed -i -e 's/te - ts/(int)(te - ts)/' ext/hpricot_scan/hpricot_css.rl || die
+}
+
+each_ruby_prepare() {
+ pushd .. &>/dev/null
+ eapply "${FILESDIR}"/${P}-fast_xs.patch
+ popd .. &>/dev/null
+}
+
+each_ruby_compile() {
+ ${RUBY} -S rake ragel || die
+
+ each_fakegem_compile
+}