summaryrefslogtreecommitdiff
path: root/dev-ruby/highline/highline-1.7.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/highline/highline-1.7.8.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/highline/highline-1.7.8.ebuild')
-rw-r--r--dev-ruby/highline/highline-1.7.8.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/highline/highline-1.7.8.ebuild b/dev-ruby/highline/highline-1.7.8.ebuild
new file mode 100644
index 000000000000..3a347a53d826
--- /dev/null
+++ b/dev-ruby/highline/highline-1.7.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.rdoc TODO"
+RUBY_FAKEGEM_DOCDIR="doc/html"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Highline is a high-level command-line IO library for ruby"
+HOMEPAGE="https://github.com/JEG2/highline"
+
+IUSE=""
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+
+all_ruby_prepare() {
+ # fix up gemspec file not to call git
+ sed -i -e '/git ls-files/d' highline.gemspec || die
+
+ # Avoid unneeded dependencies
+ sed -i -e '/\(bundler\|code_statistics\)/ s:^:#:' \
+ -e '/PackageTask/,/end/ s:^:#:' Rakefile || die
+
+ # Avoid tests that require a real console because we can't provide
+ # that when running tests through portage. These should pass when
+ # run in a console. We should probably narrow this down more to the
+ # specific tests.
+ rm test/tc_highline.rb || die
+
+ sed -i -e '/test_question_options/,/^ end/ s:^:#:' \
+ -e '/test_paged_print_infinite_loop_bug/,/^ end/ s:^:#:' \
+ -e '/test_cancel_paging/,/^ end/ s:^:#:' \
+ test/tc_menu.rb || die
+}