summaryrefslogtreecommitdiff
path: root/dev-ruby/hiera-eyaml/hiera-eyaml-3.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-ruby/hiera-eyaml/hiera-eyaml-3.1.1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-ruby/hiera-eyaml/hiera-eyaml-3.1.1.ebuild')
-rw-r--r--dev-ruby/hiera-eyaml/hiera-eyaml-3.1.1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-ruby/hiera-eyaml/hiera-eyaml-3.1.1.ebuild b/dev-ruby/hiera-eyaml/hiera-eyaml-3.1.1.ebuild
index 29e79172ccd4..cb1acb35e03f 100644
--- a/dev-ruby/hiera-eyaml/hiera-eyaml-3.1.1.ebuild
+++ b/dev-ruby/hiera-eyaml/hiera-eyaml-3.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -31,7 +31,7 @@ all_ruby_prepare() {
sed -i -e '/highline/ s/~>/>=/' \
-e '/gem.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
- sed -i -e 's:/tmp:'${T}':' \
+ sed -i -e "s:/tmp:${T}:" \
features/sandbox/puppet/environments/local/modules/test/manifests/run.pp \
features/sandbox/puppet-hiera-merge/environments/local/modules/test/manifests/run.pp \
features/puppet.feature
@@ -39,7 +39,7 @@ all_ruby_prepare() {
each_ruby_prepare() {
# Run tests with the correct ruby interpreter
- sed -i -e 's:I run `eyaml:I run `'${RUBY}' '${S}'/bin/eyaml:' features/*.feature || die
+ sed -i -e 's:I run `eyaml:I run `'${RUBY}' '"${S}"'/bin/eyaml:' features/*.feature || die
}