summaryrefslogtreecommitdiff
path: root/dev-ruby/heredoc_unindent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /dev-ruby/heredoc_unindent
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'dev-ruby/heredoc_unindent')
-rw-r--r--dev-ruby/heredoc_unindent/Manifest1
-rw-r--r--dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0-r1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/heredoc_unindent/Manifest b/dev-ruby/heredoc_unindent/Manifest
index c3c0eb81d902..53be3c5f626c 100644
--- a/dev-ruby/heredoc_unindent/Manifest
+++ b/dev-ruby/heredoc_unindent/Manifest
@@ -1,3 +1,4 @@
DIST heredoc_unindent-1.2.0.gem 10240 BLAKE2B 2d29e85e03b4da87277e82ad3c7f85f8c4f4063651a5e1aa9931ae257c8e3416b6feb6403ee158b2fb6bd4bb0b6fcf00a09bf688b3ba3acc76b5000639a7c248 SHA512 a975ffdc2ae3716a7fb90145270df03d6f3d45d42d3fca3125044a2b960a9c8ffc74a7fb0e315b6021cb6ce535b08207a40351573ed89c27fe0c8e196ea02c76
+EBUILD heredoc_unindent-1.2.0-r1.ebuild 771 BLAKE2B 403429bbeaa625ccd1bfd8d1d0b70185b3e262a759ed28a24b58ae1f0e1c54be6bdbfc9b2a768304e5377c41c1c943d669c69b2aa0f339b32328cd76a56f55fd SHA512 66f9c242255b748247f04e547f3d0141dff8e8998f73e6442b2611f8935eb11f23869aae38190034dc0ddcb991471931ed400963a333a8385ae14ac1bd50b4e8
EBUILD heredoc_unindent-1.2.0.ebuild 800 BLAKE2B b63b7487ac61219ac5acbf03f5a15a038f6654c546f819875746e2b4adb78857dc795b38bf0e5da67a1cb29abdf1e0146659e28484a271d070045600a25fadef SHA512 f1ec2cee4df88367d3b7cf2917f569edc9161af43a51006a43ec6e1aef4dd402ed09789a8fecef1281173e7cdd21fc50bfd489e8f07d728d1a41c7f0ea2538fb
MISC metadata.xml 355 BLAKE2B d6f3b21bb4e87e3eba58668a666a27da2fba665c0c96595b438564fca3fc691be1f8a5335175295617a18b3a77ec0966db5d9304de89859af6bdafc301379739 SHA512 bf551d4c3b25ce65b832a8d23fa0d333a79fff8b0681e975cb237367f0470fde3ee8a37f3df81d292915ece3a0bea6246de190880889d0f739870e106ec36978
diff --git a/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0-r1.ebuild b/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..c34fd046a74d
--- /dev/null
+++ b/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
+DESCRIPTION="Removes leading whitespace from Ruby heredocs"
+HOMEPAGE="https://github.com/adrianomitre/heredoc_unindent"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '1igem "test-unit"' test/test_heredoc_unindent.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}