summaryrefslogtreecommitdiff
path: root/dev-ruby/grpc/grpc-1.54.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-27 22:00:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-27 22:00:51 +0100
commit14fff03b5545ac6b6f575afd2e6174afbd294fdd (patch)
tree21be5aee55de4f6216e406157ad8c59a811ea202 /dev-ruby/grpc/grpc-1.54.0.ebuild
parent9f51c386724b9543e88a9c0e1be57d44326f3116 (diff)
gentoo auto-resync : 27:08:2023 - 22:00:51
Diffstat (limited to 'dev-ruby/grpc/grpc-1.54.0.ebuild')
-rw-r--r--dev-ruby/grpc/grpc-1.54.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/grpc/grpc-1.54.0.ebuild b/dev-ruby/grpc/grpc-1.54.0.ebuild
new file mode 100644
index 000000000000..35334d6cf2d4
--- /dev/null
+++ b/dev-ruby/grpc/grpc-1.54.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTENSIONS=(src/ruby/ext/grpc/extconf.rb)
+RUBY_FAKEGEM_EXTRAINSTALL="etc src"
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Send RPCs from Ruby using GRPC"
+HOMEPAGE="https://github.com/grpc/grpc"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/googleapis-common-protos-types:1
+ >=dev-ruby/google-protobuf-3.21:3
+"
+
+each_ruby_install() {
+ # Remove all the "src" bits that are not needed
+ rm -rf src/core src/ruby/spec src/ruby/ext/grpc/{libs,objs} || die
+
+ each_fakegem_install
+}