summaryrefslogtreecommitdiff
path: root/dev-ruby/git/git-1.19.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-29 13:42:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-29 13:42:04 +0000
commit5cb89cb9de4cdd1a06010c3d45748c33afab2408 (patch)
tree26bd27474f2e409c4d36a9864299f2e4cc4f87f2 /dev-ruby/git/git-1.19.0.ebuild
parent8d12644534a171c85dd84343b976054ad30faa6d (diff)
gentoo auto-resync : 29:12:2023 - 13:42:04
Diffstat (limited to 'dev-ruby/git/git-1.19.0.ebuild')
-rw-r--r--dev-ruby/git/git-1.19.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/git/git-1.19.0.ebuild b/dev-ruby/git/git-1.19.0.ebuild
new file mode 100644
index 000000000000..86a5200e027c
--- /dev/null
+++ b/dev-ruby/git/git-1.19.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="git.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for using Git in Ruby"
+HOMEPAGE="https://github.com/ruby-git/ruby-git"
+SRC_URI="https://github.com/ruby-git/ruby-git/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-git-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND+="test? ( >=dev-vcs/git-1.6.0.0 app-arch/tar )"
+RDEPEND+=">=dev-vcs/git-1.6.0.0"
+
+ruby_add_rdepend ">=dev-ruby/addressable-2.8:0 >=dev-ruby/rchardet-1.8:1"
+
+ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/minitar dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ # Don't use hardcoded /tmp directory.
+ sed -i -e "s:/tmp:${TMPDIR}:" tests/units/test_archive.rb tests/test_helper.rb || die
+
+ sed -i -e 's/__dir__/"."/' -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ git config --global user.email "git@example.com" || die
+ git config --global user.name "GitExample" || die
+ ${RUBY} -Ilib:.:tests -e 'Dir["tests/**/test_*.rb"].each {|f| require f}' || die
+}