summaryrefslogtreecommitdiff
path: root/dev-ruby/gist/gist-6.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /dev-ruby/gist/gist-6.0.0.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'dev-ruby/gist/gist-6.0.0.ebuild')
-rw-r--r--dev-ruby/gist/gist-6.0.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/gist/gist-6.0.0.ebuild b/dev-ruby/gist/gist-6.0.0.ebuild
new file mode 100644
index 000000000000..b929beb9c1c8
--- /dev/null
+++ b/dev-ruby/gist/gist-6.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Potentially the best command line gister."
+HOMEPAGE="https://github.com/defunkt/gist"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# dev-python/txgithub also installs a 'gist' binary.
+RDEPEND="!dev-python/txgithub"
+
+ruby_add_bdepend "test? ( dev-ruby/webmock )"