summaryrefslogtreecommitdiff
path: root/dev-ruby/gist/gist-5.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /dev-ruby/gist/gist-5.0.0.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'dev-ruby/gist/gist-5.0.0.ebuild')
-rw-r--r--dev-ruby/gist/gist-5.0.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/gist/gist-5.0.0.ebuild b/dev-ruby/gist/gist-5.0.0.ebuild
new file mode 100644
index 000000000000..f5655faac28f
--- /dev/null
+++ b/dev-ruby/gist/gist-5.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Potentially the best command line gister."
+HOMEPAGE="https://github.com/defunkt/gist"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# dev-python/txgithub also installs a 'gist' binary.
+RDEPEND="!dev-python/txgithub"