summaryrefslogtreecommitdiff
path: root/dev-ruby/gherkin/gherkin-5.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-02 10:47:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-02 10:47:13 +0100
commit6c14fa2586d9e9c4427b5f727dc6c8ab77587cec (patch)
tree401ffbc2ade49ce18f6182969ec5fb697a57ce48 /dev-ruby/gherkin/gherkin-5.1.0.ebuild
parentd4bd6695641f6d2ec7ff8681913d304e995902f5 (diff)
gentoo resync : 02.06.2018
Diffstat (limited to 'dev-ruby/gherkin/gherkin-5.1.0.ebuild')
-rw-r--r--dev-ruby/gherkin/gherkin-5.1.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/gherkin/gherkin-5.1.0.ebuild b/dev-ruby/gherkin/gherkin-5.1.0.ebuild
new file mode 100644
index 000000000000..0d05aa78d10f
--- /dev/null
+++ b/dev-ruby/gherkin/gherkin-5.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+# Don't install support scripts to avoid slot collisions.
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Fast Gherkin lexer and parser"
+HOMEPAGE="https://github.com/cucumber/gherkin"
+LICENSE="MIT"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+SLOT="5"
+IUSE=""