summaryrefslogtreecommitdiff
path: root/dev-ruby/filigree/filigree-0.4.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-05 22:12:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-05 22:12:15 +0100
commit0d3219165e816e09207a0e1b5b5c8ad764228615 (patch)
tree7efae0f8c1f3a14cf1039dc79a7841d094c1c4f2 /dev-ruby/filigree/filigree-0.4.1-r1.ebuild
parent05a457a80598edba136fd3a23c4477ba2f80e77c (diff)
gentoo auto-resync : 05:07:2023 - 22:12:15
Diffstat (limited to 'dev-ruby/filigree/filigree-0.4.1-r1.ebuild')
-rw-r--r--dev-ruby/filigree/filigree-0.4.1-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/filigree/filigree-0.4.1-r1.ebuild b/dev-ruby/filigree/filigree-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..a0fb519dfc0b
--- /dev/null
+++ b/dev-ruby/filigree/filigree-0.4.1-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="New classes and extensions to core library classes"
+HOMEPAGE="https://github.com/chriswailes/filigree"
+LICENSE="UoI-NCSA"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test test/ts_filigree.rb || die
+}