summaryrefslogtreecommitdiff
path: root/dev-ruby/factory_girl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/factory_girl
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/factory_girl')
-rw-r--r--dev-ruby/factory_girl/Manifest3
-rw-r--r--dev-ruby/factory_girl/factory_girl-4.8.1.ebuild49
-rw-r--r--dev-ruby/factory_girl/metadata.xml11
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-ruby/factory_girl/Manifest b/dev-ruby/factory_girl/Manifest
new file mode 100644
index 000000000000..931f12b781ae
--- /dev/null
+++ b/dev-ruby/factory_girl/Manifest
@@ -0,0 +1,3 @@
+DIST factory_girl-4.8.1.tar.gz 66262 BLAKE2B 6a90581ef7fe7f6e3d244bceebd10a4d725731ff2a7f6aae4265a6d235f5ef4f1069a0f1f2fa55121c9112b245dc947378745958583e9380536cc797d881a3aa SHA512 2c27eaec8351b009bf200e10829128c5fd3e73b0383cebf7f3ccbe062ba362b29f25e5c054ed25245202c85c6ab60c637547a8f3719e2f079c86c83c30db48a0
+EBUILD factory_girl-4.8.1.ebuild 1322 BLAKE2B 68648a2b99bbca17501728f8da93e1d7ffed5285f428a8d2e7b9a35f6739fc0d06ea8c334465ef5f543bcdc4dd85ab2c29ab7dcaf053c293c4bc5be7138cbbb1 SHA512 ddd96a37cba1dbe307cdcefa7523b9d3a929cdc79a11445c2ee820b35a261f648df79037bd042a8cdc3f8dceea2b33a6778f0549e08c25b2af584fbcfb95c0eb
+MISC metadata.xml 345 BLAKE2B 290711818c63550c33c47e1314d2e5a800f9229f44958cc06e5229a028527b455a7e7a2335fbc5e261d8b80f6d2d51e5926bb52e5d6db44d38c2ba8288bed624 SHA512 312e983fd6273c8664ddd317a6242d8176bc1ffd6f3be4842d90f4a8167c4a8e30acdac203812ead05d878d42c60588e74aaae48ee48ed0f4aa98884ddc6c6fc
diff --git a/dev-ruby/factory_girl/factory_girl-4.8.1.ebuild b/dev-ruby/factory_girl/factory_girl-4.8.1.ebuild
new file mode 100644
index 000000000000..936a4af3f63d
--- /dev/null
+++ b/dev-ruby/factory_girl/factory_girl-4.8.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+# Tests depend on unpackaged appraisal, for now we just run the specs
+# with the version of Rails that is installed.
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="GETTING_STARTED.md NEWS README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="features"
+
+inherit ruby-fakegem
+
+DESCRIPTION="factory_girl provides a framework and DSL for defining and using factories"
+HOMEPAGE="https://github.com/thoughtbot/factory_girl"
+SRC_URI="https://github.com/thoughtbot/factory_girl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activesupport-3.0.0:*"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/activerecord-3.1[sqlite]
+ dev-ruby/bourne
+ >=dev-ruby/mocha-0.12.8
+ dev-ruby/rspec-its
+ dev-ruby/timecop
+ )
+"
+
+all_ruby_prepare() {
+ # Avoid unneeded test dependencies
+ sed -i -e '/simplecov/ s:^:#:' \
+ -e '1irequire "fileutils"' spec/spec_helper.rb || die
+
+ # Avoid specs that may fail due to more strict rspec 2.99
+ # interpretation.
+ sed -i -e '/callbacks using syntax methods without referencing FactoryGirl explicitly/,/^end/ s:^:#:' spec/acceptance/callbacks_spec.rb || die
+}
diff --git a/dev-ruby/factory_girl/metadata.xml b/dev-ruby/factory_girl/metadata.xml
new file mode 100644
index 000000000000..6ecc2c07e950
--- /dev/null
+++ b/dev-ruby/factory_girl/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">thoughtbot/factory_girl</remote-id>
+ </upstream>
+</pkgmetadata>