summaryrefslogtreecommitdiff
path: root/dev-ruby/facter/facter-3.9.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-ruby/facter/facter-3.9.2-r1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-ruby/facter/facter-3.9.2-r1.ebuild')
-rw-r--r--dev-ruby/facter/facter-3.9.2-r1.ebuild89
1 files changed, 0 insertions, 89 deletions
diff --git a/dev-ruby/facter/facter-3.9.2-r1.ebuild b/dev-ruby/facter/facter-3.9.2-r1.ebuild
deleted file mode 100644
index 1c70dd61c8d8..000000000000
--- a/dev-ruby/facter/facter-3.9.2-r1.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
-
-inherit cmake-utils eutils multilib ruby-ng
-
-DESCRIPTION="A cross-platform ruby library for retrieving facts from operating systems"
-HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
-SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${S}/all/${P}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="debug test"
-KEYWORDS="amd64 ~arm ~hppa ppc ppc64 sparc x86"
-
-BDEPEND="
- >=sys-devel/gcc-4.8:*
- >=dev-libs/leatherman-1.0.0
- dev-cpp/cpp-hocon"
-CDEPEND="
- dev-libs/openssl:0=
- sys-apps/util-linux
- app-emulation/virt-what
- net-misc/curl
- >=dev-libs/boost-1.54[nls]
- <dev-libs/boost-1.70.0
- >=dev-cpp/yaml-cpp-0.5.1
- !<app-admin/puppet-4.0.0"
-
-RDEPEND="${CDEPEND}"
-DEPEND="${BDEPEND}
- ${CDEPEND}"
-
-src_prepare() {
- # Remove the code that installs facter.rb to the wrong directory.
- sed -i '/install(.*facter\.rb/d' lib/CMakeLists.txt || die
- sed -i '/install(.*facter\.jar/d' lib/CMakeLists.txt || die
- # make it support multilib
- sed -i "s/\ lib)/\ $(get_libdir))/g" lib/CMakeLists.txt || die
- sed -i "s/lib\")/$(get_libdir)\")/g" CMakeLists.txt || die
- # make the require work
- sed -i 's/\${LIBFACTER_INSTALL_DESTINATION}\///g' lib/facter.rb.in || die
- # patches
- default
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_VERBOSE_MAKEFILE=ON
- -DCMAKE_BUILD_TYPE=None
- -DCMAKE_INSTALL_PREFIX=/usr
- -DCMAKE_INSTALL_SYSCONFDIR=/etc
- -DCMAKE_INSTALL_LOCALSTATEDIR=/var
- -DUSE_JRUBY_SUPPORT=FALSE
- -DBLKID_LIBRARY=/$(get_libdir)/libblkid.so.1
- )
- if use debug; then
- mycmakeargs+=(
- -DCMAKE_BUILD_TYPE=Debug
- )
- fi
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-each_ruby_install() {
- doruby "${BUILD_DIR}"/lib/facter.rb
-}
-
-src_test() {
- cmake-utils_src_test
-}
-
-src_install() {
- cmake-utils_src_install
- ruby-ng_src_install
-
- # need a variable file in env.d :(
- diropts -m0755
- dodir /etc/env.d
- echo -n "FACTERDIR=/usr/$(get_libdir)" > "${D}/etc/env.d/00facterdir"
- fperms 0644 /etc/env.d/00facterdir
-}