summaryrefslogtreecommitdiff
path: root/dev-ruby/execjs/execjs-2.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-17 11:03:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-17 11:03:04 +0100
commit0968caae52d6eae7513e2ce4e0900a2e009780ee (patch)
tree54218d0d3baaf14b964427f98c4f90f13380ffd3 /dev-ruby/execjs/execjs-2.9.1.ebuild
parent58018a2c9504435bb719f2d60439ebe22fbeb503 (diff)
gentoo auto-resync : 17:09:2023 - 11:03:03
Diffstat (limited to 'dev-ruby/execjs/execjs-2.9.1.ebuild')
-rw-r--r--dev-ruby/execjs/execjs-2.9.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/execjs/execjs-2.9.1.ebuild b/dev-ruby/execjs/execjs-2.9.1.ebuild
new file mode 100644
index 000000000000..ad23c4d39afd
--- /dev/null
+++ b/dev-ruby/execjs/execjs-2.9.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+inherit ruby-fakegem
+
+DESCRIPTION="ExecJS lets you run JavaScript code from Ruby"
+HOMEPAGE="https://github.com/rails/execjs"
+SRC_URI="https://github.com/rails/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x64-macos"
+
+IUSE="test"
+
+# execjs supports various javascript runtimes. They are listed in order
+# as per the documentation. For now only include the ones already in the
+# tree.
+
+RDEPEND+=" || ( dev-ruby/duktape-rb net-libs/nodejs )"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" Rakefile || die
+ # Avoid test requiring network connectivity. We could potentially
+ # substitute dev-ruby/coffee-script-source for this.
+ sed -i -e '/test_coffeescript/,/end/ s:^:#:' test/test_execjs.rb || die
+}