summaryrefslogtreecommitdiff
path: root/dev-ruby/dotenv/dotenv-2.5.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-ruby/dotenv/dotenv-2.5.0-r1.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-ruby/dotenv/dotenv-2.5.0-r1.ebuild')
-rw-r--r--dev-ruby/dotenv/dotenv-2.5.0-r1.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-ruby/dotenv/dotenv-2.5.0-r1.ebuild b/dev-ruby/dotenv/dotenv-2.5.0-r1.ebuild
deleted file mode 100644
index f4d2a225eb25..000000000000
--- a/dev-ruby/dotenv/dotenv-2.5.0-r1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_EXTRADOC="README.md Changelog.md"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Loads environment variables from .env into ENV"
-HOMEPAGE="https://github.com/bkeepers/dotenv"
-SRC_URI="https://github.com/bkeepers/dotenv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT"
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="2"
-IUSE=""
-
-ruby_add_bdepend "test? ( dev-ruby/spring dev-ruby/rails )"
-
-all_ruby_prepare() {
- sed -i -e '/:guard/,/end/ s:^:#:' \
- -e '5igem "rspec", "~> 3.0"' Gemfile || die
-
- sed -i -e '/rubocop/ s:^:#:' -e 's/git ls-files/find/' dotenv.gemspec || die
-}
-
-each_ruby_prepare() {
- sed -i -e "s:ruby -v:${RUBY} -v:g" spec/dotenv/parser_spec.rb || die
-}