summaryrefslogtreecommitdiff
path: root/dev-ruby/diva/diva-1.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-ruby/diva/diva-1.0.2.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-ruby/diva/diva-1.0.2.ebuild')
-rw-r--r--dev-ruby/diva/diva-1.0.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/diva/diva-1.0.2.ebuild b/dev-ruby/diva/diva-1.0.2.ebuild
new file mode 100644
index 000000000000..6134a6d9ab7a
--- /dev/null
+++ b/dev-ruby/diva/diva-1.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="diva.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implementation of expression for handling things."
+HOMEPAGE="https://github.com/toshia/diva"
+SRC_URI="https://github.com/toshia/diva/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "<dev-ruby/addressable-2.8"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}