summaryrefslogtreecommitdiff
path: root/dev-ruby/diff-lcs/diff-lcs-1.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-01 11:48:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-01 11:48:39 +0000
commit1e39e6a8c127767a57f0465ed9ece4fefb44b4ae (patch)
tree3559e11cac3d1d8c48d4a253876d1927017c508f /dev-ruby/diff-lcs/diff-lcs-1.5.1.ebuild
parentd13aef5a4ce5eb3b31565d0d9e67e903e5e932df (diff)
gentoo auto-resync : 01:02:2024 - 11:48:38
Diffstat (limited to 'dev-ruby/diff-lcs/diff-lcs-1.5.1.ebuild')
-rw-r--r--dev-ruby/diff-lcs/diff-lcs-1.5.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/diff-lcs/diff-lcs-1.5.1.ebuild b/dev-ruby/diff-lcs/diff-lcs-1.5.1.ebuild
new file mode 100644
index 000000000000..6c8b61e3ef2f
--- /dev/null
+++ b/dev-ruby/diff-lcs/diff-lcs-1.5.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Use the McIlroy-Hunt LCS algorithm to compute differences"
+HOMEPAGE="https://github.com/halostatue/diff-lcs"
+
+LICENSE="|| ( Artistic MIT GPL-2+ )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+each_ruby_prepare() {
+ # Use the current ruby to test script invocation
+ sed -e "/system/ s:ruby:${RUBY}:" \
+ -i spec/ldiff_spec.rb || die
+}