summaryrefslogtreecommitdiff
path: root/dev-ruby/diff-lcs/diff-lcs-1.2.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/diff-lcs/diff-lcs-1.2.5-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/diff-lcs/diff-lcs-1.2.5-r1.ebuild')
-rw-r--r--dev-ruby/diff-lcs/diff-lcs-1.2.5-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ruby/diff-lcs/diff-lcs-1.2.5-r1.ebuild b/dev-ruby/diff-lcs/diff-lcs-1.2.5-r1.ebuild
new file mode 100644
index 000000000000..a1a0b154295a
--- /dev/null
+++ b/dev-ruby/diff-lcs/diff-lcs-1.2.5-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Use the McIlroy-Hunt LCS algorithm to compute differences"
+HOMEPAGE="https://github.com/halostatue/diff-lcs"
+
+LICENSE="|| ( MIT Ruby GPL-2 )"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""