summaryrefslogtreecommitdiff
path: root/dev-ruby/dependor/dependor-1.0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-ruby/dependor/dependor-1.0.1-r1.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-ruby/dependor/dependor-1.0.1-r1.ebuild')
-rw-r--r--dev-ruby/dependor/dependor-1.0.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/dependor/dependor-1.0.1-r1.ebuild b/dev-ruby/dependor/dependor-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..24455dba0a49
--- /dev/null
+++ b/dev-ruby/dependor/dependor-1.0.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Reduces duplication when doing manual dependency injection"
+HOMEPAGE="https://github.com/psyho/dependor"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -e '/simplecov/,/^end/ s:^:#:' \
+ -e '/color_enabled/ s:^:#:' \
+ -i spec/spec_helper.rb || die
+}