summaryrefslogtreecommitdiff
path: root/dev-ruby/csv/csv-3.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-23 13:01:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-23 13:01:09 +0000
commitacc2dacf2ee9a5b03df96da670153f2e3a24d80c (patch)
tree852bc5b5f64c3dc59ac09c6a2314c63b9a901ac0 /dev-ruby/csv/csv-3.3.0.ebuild
parent2c9b8fbe41c04a94054b0540b54fcf2de0b79166 (diff)
gentoo auto-resync : 23:03:2024 - 13:01:09
Diffstat (limited to 'dev-ruby/csv/csv-3.3.0.ebuild')
-rw-r--r--dev-ruby/csv/csv-3.3.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/csv/csv-3.3.0.ebuild b/dev-ruby/csv/csv-3.3.0.ebuild
new file mode 100644
index 000000000000..a989a2e126c6
--- /dev/null
+++ b/dev-ruby/csv/csv-3.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The CSV library provides a complete interface to CSV files and data"
+HOMEPAGE="https://github.com/ruby/csv"
+SRC_URI="https://github.com/ruby/csv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+SLOT="$(ver_cut 1)"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-3.4.8 )"
+
+all_ruby_prepare() {
+ sed -i -e 's:require_relative ":require "./:' -e 's/__dir__/"."/' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} run-test.rb || die
+}