summaryrefslogtreecommitdiff
path: root/dev-ruby/crass/crass-1.0.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-ruby/crass/crass-1.0.6-r1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-ruby/crass/crass-1.0.6-r1.ebuild')
-rw-r--r--dev-ruby/crass/crass-1.0.6-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/crass/crass-1.0.6-r1.ebuild b/dev-ruby/crass/crass-1.0.6-r1.ebuild
new file mode 100644
index 000000000000..ff15460fdf3f
--- /dev/null
+++ b/dev-ruby/crass/crass-1.0.6-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="HISTORY.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="crass.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby CSS parser that's fully compliant with the CSS Syntax Level 3 specification"
+HOMEPAGE="https://github.com/rgrove/crass/"
+SRC_URI="https://github.com/rgrove/crass/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend ">=dev-ruby/minitest-5.0.8:5"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}