summaryrefslogtreecommitdiff
path: root/dev-ruby/countdownlatch/countdownlatch-1.0.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /dev-ruby/countdownlatch/countdownlatch-1.0.0-r2.ebuild
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'dev-ruby/countdownlatch/countdownlatch-1.0.0-r2.ebuild')
-rw-r--r--dev-ruby/countdownlatch/countdownlatch-1.0.0-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/countdownlatch/countdownlatch-1.0.0-r2.ebuild b/dev-ruby/countdownlatch/countdownlatch-1.0.0-r2.ebuild
new file mode 100644
index 000000000000..3b5c7208e942
--- /dev/null
+++ b/dev-ruby/countdownlatch/countdownlatch-1.0.0-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Synchronization aid to allow threads to wait for operations in other threads"
+HOMEPAGE="https://github.com/benlangfeld/countdownlatch"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+}