summaryrefslogtreecommitdiff
path: root/dev-ruby/coolio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-02 22:51:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-02 22:51:20 +0100
commit1e9c38efad2f42ea208e40924d1e5936810ac7c0 (patch)
treedbcaa52c820c84eaba974e8a5bf4ba2b05a4bed2 /dev-ruby/coolio
parent1f6d51a43dbfcb87ef81da70c688d354560e846a (diff)
gentoo auto-resync : 02:08:2023 - 22:51:19
Diffstat (limited to 'dev-ruby/coolio')
-rw-r--r--dev-ruby/coolio/Manifest2
-rw-r--r--dev-ruby/coolio/coolio-1.7.1-r2.ebuild48
-rw-r--r--dev-ruby/coolio/files/coolio-1.7.1-fix-build-clang16.patch13
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-ruby/coolio/Manifest b/dev-ruby/coolio/Manifest
index e4fc9b1f5c2b..d10a0a22fb3d 100644
--- a/dev-ruby/coolio/Manifest
+++ b/dev-ruby/coolio/Manifest
@@ -1,3 +1,5 @@
+AUX coolio-1.7.1-fix-build-clang16.patch 621 BLAKE2B 8f76b0e5dc380c0ba199d63620fe92b42bacd014357d5635c26931b3c11df81607bf191ce44e5713446886055f8ef8fb67eca36ba6fdf946663cc1390c47782a SHA512 3aa78a96ee79a09dedc876905f9945111b74f18bf80adb9911cde98d85df3ce0da63456bb62d14587295010f4fc2bd9a1fd3fbe2d6e93e43085c607eca607dee
DIST cool.io-1.7.1.gem 112640 BLAKE2B 107d7541180de46c78542eab4b131220c4ae4a10210c7ff870f54eb24178b364fcac1abc4b93f8d0eccea197fb746cede95416aea8f3d5cc458626b1fa9a02f4 SHA512 9ab3e6ddd1689b2825f9bd82714b4ef5ac921dc4b2f84786971c3ec448577613cee73084c99090382878b0da43c9228cb2fd3a8627dc8f62ceeeff274dbdc929
EBUILD coolio-1.7.1-r1.ebuild 1246 BLAKE2B 351713d2bc41c7540e7e41a1e4ffa77eb5acc0a50008ab8290e699e5b06bb29dcdc2bf079216351e759b6a84cae05b94c0e23819ad0323bf009b807e20a2766a SHA512 7bab35cf46c3e430eebf1c6c3c2583de5e02c5a10f0f10d6942005ac47e4b3bf149c014342774023ff228f4cf1a2b044e6fe7580cb218759bfb2ecf4192a602f
+EBUILD coolio-1.7.1-r2.ebuild 1310 BLAKE2B eff67d693e63777b25ca2fe2854e334794b68435d50b8762f4dbd365ba09c7c2af1071fda8eb97f6c5351241871f38a906f0fe8461183e941e867f8b8e79c5f1 SHA512 453c6f244ed1cc92d994cef1138250f89fc04ad7e030487cccb1a2c96b5eb4e036575b86290f429df607c37732f8c7484be98d6373d92581d4483c9b244505ef
MISC metadata.xml 326 BLAKE2B 5d9e962ae23bfeee79add4ea81a0e221695d07de536ae6fb5fd8fc8b5b97ec09e0c5cabdd379fba8d48f5248e94aeca05e7c9f6d9954bd9b017ca9e6542101b7 SHA512 392df388283e8251fcfffe3d67462b8a4ea91b1d655f444610a53536df5c8e6f0217de0612405317ad6e1644b5cdb2c6c0e22c22f7b60156e69526c200bad646
diff --git a/dev-ruby/coolio/coolio-1.7.1-r2.ebuild b/dev-ruby/coolio/coolio-1.7.1-r2.ebuild
new file mode 100644
index 000000000000..538c9aad48f1
--- /dev/null
+++ b/dev-ruby/coolio/coolio-1.7.1-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+RUBY_FAKEGEM_NAME="cool.io"
+
+RUBY_FAKEGEM_GEMSPEC="cool.io.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/cool.io/extconf.rb ext/iobuffer/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="A high performance event framework for Ruby which uses the libev C library"
+HOMEPAGE="https://coolio.github.io/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.1-fix-build-clang16.patch
+)
+
+# cool.io includes a bundled version of libev that is patched to work correctly with ruby.
+
+all_ruby_prepare() {
+ rm -r Gemfile* lib/.gitignore || die
+
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -i -e '28i s.add_dependency "iobuffer"' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid dependency on rake-compiler
+ sed -i -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/^end/ s:^:#:' Rakefile || die
+
+ # Remove specs that require network connectivity
+ rm -f spec/dns_spec.rb || die
+
+ # Use one address consistently
+ sed -i -e 's/localhost/127.0.0.1/' spec/{udp_socket,tcp_server,iobuffer}_spec.rb || die
+}
diff --git a/dev-ruby/coolio/files/coolio-1.7.1-fix-build-clang16.patch b/dev-ruby/coolio/files/coolio-1.7.1-fix-build-clang16.patch
new file mode 100644
index 000000000000..909988fda7c3
--- /dev/null
+++ b/dev-ruby/coolio/files/coolio-1.7.1-fix-build-clang16.patch
@@ -0,0 +1,13 @@
+Bug: https://bugs.gentoo.org/883147
+Upstream PR: https://github.com/tarcieri/cool.io/pull/78
+--- a/ext/libev/ev.c
++++ b/ext/libev/ev.c
+@@ -3768,7 +3768,7 @@ rb_thread_unsafe_dangerous_crazy_blocking_region_end(...);
+ #if defined(HAVE_RB_THREAD_BLOCKING_REGION) || defined(HAVE_RB_THREAD_CALL_WITHOUT_GVL)
+ poll_args.loop = loop;
+ poll_args.waittime = waittime;
+- rb_thread_call_without_gvl(ev_backend_poll, (void *)&poll_args, RUBY_UBF_IO, 0);
++ rb_thread_call_without_gvl((void *)ev_backend_poll, (void *)&poll_args, RUBY_UBF_IO, 0);
+ #else
+ backend_poll (EV_A_ waittime);
+ #endif