summaryrefslogtreecommitdiff
path: root/dev-ruby/contracts/contracts-0.17.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-22 06:41:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-22 06:41:43 +0000
commitaaeed2da8906f11cba80355688015d74b01cc604 (patch)
tree5d714c0600fd3f185c0ddb96eef8dd41a5f3ec5e /dev-ruby/contracts/contracts-0.17.ebuild
parent23b767af73549eeb4dd3069e09d0f2fcb88669a8 (diff)
gentoo auto-resync : 22:03:2023 - 06:41:43
Diffstat (limited to 'dev-ruby/contracts/contracts-0.17.ebuild')
-rw-r--r--dev-ruby/contracts/contracts-0.17.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-ruby/contracts/contracts-0.17.ebuild b/dev-ruby/contracts/contracts-0.17.ebuild
index 66484ff56a9d..dfd63b733363 100644
--- a/dev-ruby/contracts/contracts-0.17.ebuild
+++ b/dev-ruby/contracts/contracts-0.17.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,3 +17,11 @@ LICENSE="MIT"
SLOT="$(ver_cut 1-2)"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
IUSE=""
+
+each_ruby_test() {
+ # COLUMNS needed for:
+ # ./spec/contracts_spec.rb:654 # Contracts: Contracts to_s formatting in expected should wrap and pretty print for long return contracts
+ # ./spec/contracts_spec.rb:643 # Contracts: Contracts to_s formatting in expected should wrap and pretty print for long param contracts
+ local -x COLUMNS=80
+ each_fakegem_test
+}