summaryrefslogtreecommitdiff
path: root/dev-ruby/console/console-1.23.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-07 13:06:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-07 13:06:42 +0000
commit1b97f0352e38f8346984329b82a8be71632220a6 (patch)
treea2eedd48c9161522b87c70d55cbb7d28d2cb36a9 /dev-ruby/console/console-1.23.5.ebuild
parenta03bc69159ecc073f051ca2079848553a8e34664 (diff)
gentoo auto-resync : 07:03:2024 - 13:06:41
Diffstat (limited to 'dev-ruby/console/console-1.23.5.ebuild')
-rw-r--r--dev-ruby/console/console-1.23.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/console/console-1.23.5.ebuild b/dev-ruby/console/console-1.23.5.ebuild
new file mode 100644
index 000000000000..6fd98395ebfd
--- /dev/null
+++ b/dev-ruby/console/console-1.23.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="readme.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="sus"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Beautiful logging for Ruby"
+HOMEPAGE="https://github.com/socketry/console"
+SRC_URI="https://github.com/socketry/console/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/fiber-annotation
+ dev-ruby/fiber-local
+ dev-ruby/json
+"
+
+all_ruby_prepare() {
+ sed -i -E 's/require_relative "(.+)"/require File.expand_path("\1")/g' "${RUBY_FAKEGEM_GEMSPEC}" || die
+
+ # Avoid dependency on covered.
+ rm -f config/sus.rb || die
+
+ # Avoid sandbox violation during tests
+ sed -i -e 's:/tmp/:'"${TMPDIR}"'/:' test/console/output.rb || die
+}