summaryrefslogtreecommitdiff
path: root/dev-ruby/console/console-1.23.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-22 12:05:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-22 12:05:36 +0100
commit02eb6576978c38afed5787f6f2dbab8353379d66 (patch)
tree0b82220aae58c1307bef3aff0f342f4cdf858161 /dev-ruby/console/console-1.23.3.ebuild
parent490ef2c2dc8b4e808f37add1adee21a754efd9a9 (diff)
gentoo auto-resync : 22:04:2024 - 12:05:36
Diffstat (limited to 'dev-ruby/console/console-1.23.3.ebuild')
-rw-r--r--dev-ruby/console/console-1.23.3.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-ruby/console/console-1.23.3.ebuild b/dev-ruby/console/console-1.23.3.ebuild
deleted file mode 100644
index 8b8d705f1679..000000000000
--- a/dev-ruby/console/console-1.23.3.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby31 ruby32 ruby33"
-
-RUBY_FAKEGEM_EXTRADOC="readme.md"
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-RUBY_FAKEGEM_RECIPE_TEST="sus"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Beautiful logging for Ruby"
-HOMEPAGE="https://github.com/socketry/console"
-SRC_URI="https://github.com/socketry/console/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1)"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE=""
-
-ruby_add_rdepend "
- dev-ruby/fiber-annotation
- dev-ruby/fiber-local
-"
-
-all_ruby_prepare() {
- sed -i -E 's/require_relative "(.+)"/require File.expand_path("\1")/g' "${RUBY_FAKEGEM_GEMSPEC}" || die
-
- # Avoid dependency on covered.
- rm -f config/sus.rb || die
-
- # Avoid sandbox violation during tests
- sed -i -e 's:/tmp/:'"${TMPDIR}"'/:' test/console/output.rb || die
-}