summaryrefslogtreecommitdiff
path: root/dev-ruby/connection_pool/connection_pool-2.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/connection_pool/connection_pool-2.2.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/connection_pool/connection_pool-2.2.1.ebuild')
-rw-r--r--dev-ruby/connection_pool/connection_pool-2.2.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/connection_pool/connection_pool-2.2.1.ebuild b/dev-ruby/connection_pool/connection_pool-2.2.1.ebuild
new file mode 100644
index 000000000000..eaf2366fa376
--- /dev/null
+++ b/dev-ruby/connection_pool/connection_pool-2.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changes.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Generic connection pooling for Ruby"
+HOMEPAGE="https://github.com/mperham/connection_pool"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5 )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' connection_pool.gemspec || die
+ sed -i -e '/bundler/d' Rakefile || die
+ sed -i -e "s/gem 'minitest'/gem 'minitest', '~> 5.0'/" test/helper.rb || die
+}