summaryrefslogtreecommitdiff
path: root/dev-ruby/compass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/compass
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/compass')
-rw-r--r--dev-ruby/compass/Manifest3
-rw-r--r--dev-ruby/compass/compass-1.0.3-r1.ebuild42
-rw-r--r--dev-ruby/compass/metadata.xml16
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-ruby/compass/Manifest b/dev-ruby/compass/Manifest
new file mode 100644
index 000000000000..80c7f67d54be
--- /dev/null
+++ b/dev-ruby/compass/Manifest
@@ -0,0 +1,3 @@
+DIST compass-1.0.3.gem 378368 BLAKE2B 1c33f576ba0c1117d8ca3deeb4d422441fd50922df3443a68b4eeabdd45d804fe505461a687053b6a0ebf0a2aed2539482843eac786226d16ad5ea5fb51a5284 SHA512 bef1ca903cb982df39330a913051c1a330aa1ecad9abbe5a7644e335c7ed2d152901a4079cc5ee43e9f7ce85a671f1d5552a3c98cf40b04134de072a120deef6
+EBUILD compass-1.0.3-r1.ebuild 1068 BLAKE2B c7d220b6f19fe3228a77b556fdf4b0ad159266d226f2ed16bccab50ed7d1bd5333f9183a608276fd5bf036bb548d04fba3c8cb6ad386d6410ff6f52fa248e33a SHA512 c55d350543ca0614f2c0b82eb93c23a424d23f71ef63c7988d444066cea4b2b807e18143ae38fea6bd843122ef64db234d49172ca5a3425f272204ec1336eb6f
+MISC metadata.xml 528 BLAKE2B 6b7fabfe814d39ca5c07dde758c678e7a2e3bbf683a8e156145ee385060d9454947660d2ffc44a4a5426965ae81064e565c2e3191ff5d8fbe6e87b31f551565f SHA512 c65b8d5e0ea0caa17062ad77c8f099a6c2d61f1bc5f32c635c5bad5bc4fc571703b56cecef1eb2db34a932d02cd4ae4f7cce18ea86d632f0fbd4a9993d431dd8
diff --git a/dev-ruby/compass/compass-1.0.3-r1.ebuild b/dev-ruby/compass/compass-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..cc402da8bb91
--- /dev/null
+++ b/dev-ruby/compass/compass-1.0.3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_TASK_TEST="-Ilib test features"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION VERSION_NAME"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Compass Stylesheet Authoring Framework"
+HOMEPAGE="http://compass-style.org/"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Gem does not contain all files needed to run specs and it is not clear
+# which upstream repository/branch/directory to use.
+RESTRICT="test"
+
+ruby_add_rdepend ">=dev-ruby/chunky_png-1.2
+ >=dev-ruby/compass-core-1.0.2:1.0
+ >=dev-ruby/compass-import-once-1.0.5:1.0
+ >=dev-ruby/rb-inotify-0.9
+ >=dev-ruby/sass-3.3.13:* <dev-ruby/sass-3.5:*
+ !!<dev-ruby/compass-0.12.7-r1"
+
+#ruby_add_bdepend "test? ( dev-ruby/colorize )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+
+ # Remove rb-fsevent dependency since it is not needed on Linux and
+ # not packaged.
+ sed -i -e '/rb-fsevent/,/^-/ s:^:#:' ../metadata || die
+}
diff --git a/dev-ruby/compass/metadata.xml b/dev-ruby/compass/metadata.xml
new file mode 100644
index 000000000000..d874026db26b
--- /dev/null
+++ b/dev-ruby/compass/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>vikraman@gentoo.org</email>
+ <name>Vikraman Choudhury (vikraman)</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Compass is a Sass-based Stylesheet Framework that streamlines the
+ creation and maintenance of CSS.
+ </longdescription>
+</pkgmetadata>