summaryrefslogtreecommitdiff
path: root/dev-ruby/compass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/compass
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/compass')
-rw-r--r--dev-ruby/compass/Manifest5
-rw-r--r--dev-ruby/compass/compass-1.0.3-r1.ebuild42
-rw-r--r--dev-ruby/compass/metadata.xml16
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-ruby/compass/Manifest b/dev-ruby/compass/Manifest
new file mode 100644
index 000000000000..5dd042d73d5f
--- /dev/null
+++ b/dev-ruby/compass/Manifest
@@ -0,0 +1,5 @@
+DIST compass-1.0.3.gem 378368 SHA256 4c7884dc5349d59011fd6c5736a0404008d5609235037741feac9c8ff840d151 SHA512 bef1ca903cb982df39330a913051c1a330aa1ecad9abbe5a7644e335c7ed2d152901a4079cc5ee43e9f7ce85a671f1d5552a3c98cf40b04134de072a120deef6 WHIRLPOOL b1b07e028dffcb370abca70815442758691e7373bac8b51b994136bb0a746eec4d79fddbad53c431286ff58d7bd9aaf49619e72f7a926b8c18b5dc7ca0f15e09
+EBUILD compass-1.0.3-r1.ebuild 1068 SHA256 07f656d13765e92efaeb94e804eb6f849279ddcab5d5acae335d694a032ebe3f SHA512 312ddca9b3208ab48c7507c33aa4f55fcce465d98aecd43891ea231aec67dd3fd9c40d3a76dd1d63915ce10d5eb57e53e7d4259641c0010d412a4858bb2e3929 WHIRLPOOL d0a3c5b3ad6cec2fbbaf50072e24743e1e531b16abd38aef208fb64616743b1a33723cb476dc6d373ce7b3e5070ea50b07275b8c09768d11b8827f2ba5d13ff5
+MISC ChangeLog 2862 SHA256 48ed0c4446dc9acabe42e244de2f76d778ff5a09fbc994176aa63de52c57fe73 SHA512 ac94f30a75d19b9f98e9a0ba59bad9bde56d1e240f20915450d7fecb84a0a1fab31623e1491d80815bbba5184108bf9c749ef53e233b7b549cf47acb1cffcc56 WHIRLPOOL 37e6b2176f09f6f73e1e63d211648395c826f19ded65e2af3352842fb4aa99000b9a8cd2b644c4fe2a1703cb732ef5becc8759b3d2bce6cc0cf99f639a3e79a4
+MISC ChangeLog-2015 1794 SHA256 713feb08f5ee9e2ccb01dee11cf5ec74f5415a1ba919fe3e86d3d2f160a38b87 SHA512 087534657d97566affc3c4bfef4e5289b29a5efcef42d8bb09ab8df11bf43c5dd7c97cbd219f98afc5f9dbe189261d105e9c817e7a616af5a41fe6376bc13beb WHIRLPOOL 8cb284a49bf0a05cb00f098665a1c97d437a00e383d44f724c6ba234a8e9df4f5c19f90726782d285e824704de186c425295c1280766eb9d4da6784e03bce1fe
+MISC metadata.xml 528 SHA256 0305f5b1d1527b892c6759045a708605a5c5d65cab77d79b7e8d97ac05e61669 SHA512 c65b8d5e0ea0caa17062ad77c8f099a6c2d61f1bc5f32c635c5bad5bc4fc571703b56cecef1eb2db34a932d02cd4ae4f7cce18ea86d632f0fbd4a9993d431dd8 WHIRLPOOL 5a8b13164f4e60e2fc03978218c03b2351e993941429fa49dbbabc7b9d1b64088f3287a9d6cf2fc65eff9112e9555f860f0b3a25fc66b689ddf189e8fc7442df
diff --git a/dev-ruby/compass/compass-1.0.3-r1.ebuild b/dev-ruby/compass/compass-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..35064a11d33a
--- /dev/null
+++ b/dev-ruby/compass/compass-1.0.3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_TASK_TEST="-Ilib test features"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION VERSION_NAME"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Compass Stylesheet Authoring Framework"
+HOMEPAGE="http://compass-style.org/"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Gem does not contain all files needed to run specs and it is not clear
+# which upstream repository/branch/directory to use.
+RESTRICT="test"
+
+ruby_add_rdepend ">=dev-ruby/chunky_png-1.2
+ >=dev-ruby/compass-core-1.0.2:1.0
+ >=dev-ruby/compass-import-once-1.0.5:1.0
+ >=dev-ruby/rb-inotify-0.9
+ >=dev-ruby/sass-3.3.13:* <dev-ruby/sass-3.5:*
+ !!<dev-ruby/compass-0.12.7-r1"
+
+#ruby_add_bdepend "test? ( dev-ruby/colorize )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+
+ # Remove rb-fsevent dependency since it is not needed on Linux and
+ # not packaged.
+ sed -i -e '/rb-fsevent/,/^-/ s:^:#:' ../metadata || die
+}
diff --git a/dev-ruby/compass/metadata.xml b/dev-ruby/compass/metadata.xml
new file mode 100644
index 000000000000..d874026db26b
--- /dev/null
+++ b/dev-ruby/compass/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>vikraman@gentoo.org</email>
+ <name>Vikraman Choudhury (vikraman)</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Compass is a Sass-based Stylesheet Framework that streamlines the
+ creation and maintenance of CSS.
+ </longdescription>
+</pkgmetadata>