summaryrefslogtreecommitdiff
path: root/dev-ruby/colorize/colorize-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-26 01:31:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-26 01:31:19 +0100
commitd2b7cca519cd1aa575ebbc562c57071266ae63f1 (patch)
tree20d2a4b55096c14c4effc9e92ab6001fca68544d /dev-ruby/colorize/colorize-1.1.0.ebuild
parent6fe5af3f06c92a6b1a6b21ff5e1bc9d107490971 (diff)
gentoo auto-resync : 26:06:2023 - 01:31:19
Diffstat (limited to 'dev-ruby/colorize/colorize-1.1.0.ebuild')
-rw-r--r--dev-ruby/colorize/colorize-1.1.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/colorize/colorize-1.1.0.ebuild b/dev-ruby/colorize/colorize-1.1.0.ebuild
new file mode 100644
index 000000000000..4dce118faff0
--- /dev/null
+++ b/dev-ruby/colorize/colorize-1.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_TASK_TEST="default"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Adds methods to set color, background color and text effect on console easier"
+HOMEPAGE="https://github.com/fazibear/colorize"
+LICENSE="GPL-2+"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Cc]ode[Cc]limate/d" test/test_colorize.rb || die
+
+ # Skip unpackaged test as this release is not tagged upstream.
+ sed -i -e '/test_\(colorize\|colorized_string\)_with_readline/,/execute/ s:^:#:' Rakefile || die
+}