summaryrefslogtreecommitdiff
path: root/dev-ruby/colorator/colorator-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/colorator/colorator-1.1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/colorator/colorator-1.1.0.ebuild')
-rw-r--r--dev-ruby/colorator/colorator-1.1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/colorator/colorator-1.1.0.ebuild b/dev-ruby/colorator/colorator-1.1.0.ebuild
new file mode 100644
index 000000000000..b2b03e90105b
--- /dev/null
+++ b/dev-ruby/colorator/colorator-1.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Colorize your text in the terminal"
+HOMEPAGE="https://github.com/octopress/colorator"
+SRC_URI="https://github.com/octopress/colorator/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" Rakefile || die
+ sed -i -e "/luna/d" spec/spec/helper.rb || die
+}