summaryrefslogtreecommitdiff
path: root/dev-ruby/color
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/color
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/color')
-rw-r--r--dev-ruby/color/Manifest3
-rw-r--r--dev-ruby/color/color-1.8.ebuild28
-rw-r--r--dev-ruby/color/metadata.xml11
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/color/Manifest b/dev-ruby/color/Manifest
new file mode 100644
index 000000000000..5a70ea20c218
--- /dev/null
+++ b/dev-ruby/color/Manifest
@@ -0,0 +1,3 @@
+DIST color-1.8.tar.gz 42530 BLAKE2B 4a0f0ff4d4f82530fab5bad345350ea0cd983bc7d1bd8898c8a4da16de788efc908cff919d622ce0a9c445257e1dfef0adda4b29641d3eda55d0a8c917db932f SHA512 be48a8895b5dd33326a9debe250c87df37025eb2dca05a0eb61b82b31dbc1ee27c175fc1e37262bce88729e882dfb66f449a3a29c76b9ef0ac2064ffa2b4266c
+EBUILD color-1.8.ebuild 652 BLAKE2B e39e62397ebc5eb3bc3bf3fd4c691db819fdf4ad114018d52578c58546bdf56b4921f5b6894b6cd59b09e0037ad01ebf0fd7a76db7edc2b6c398df424d95fd88 SHA512 cfc2c48710a7574c35b40f9a70a29b321539ccb4af12e8761efe44c9f7e1f803110b851e52e7cb7144263d1ff15cbb7baa93d7437fa1ecdb857ded0554e6d9cb
+MISC metadata.xml 342 BLAKE2B d6dd3d97d5d8e17debd8cc9936419a763c876643613f77ba26d8192a07830b5378acfb6dc2ec91e3b04de85096047505f6c7513950afc33dcb8867f49f13627d SHA512 fdf898845d12fcdf5e859e218955efbd245d98f6be064af977cb651723f1f1575ab5019cc77c0afd3d45fc13620672d16921fd5e9d09e88295f0b42d8a8835aa
diff --git a/dev-ruby/color/color-1.8.ebuild b/dev-ruby/color/color-1.8.ebuild
new file mode 100644
index 000000000000..fe96bea38762
--- /dev/null
+++ b/dev-ruby/color/color-1.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Colour management with Ruby"
+HOMEPAGE="https://github.com/halostatue/color"
+SRC_URI="https://github.com/halostatue/color/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/minitest-5.0
+ )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e "Dir['test/test_*.rb'].each{|f| require f}" || die
+}
diff --git a/dev-ruby/color/metadata.xml b/dev-ruby/color/metadata.xml
new file mode 100644
index 000000000000..5fdac5e571f7
--- /dev/null
+++ b/dev-ruby/color/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">halostatue/color</remote-id>
+ </upstream>
+</pkgmetadata>