summaryrefslogtreecommitdiff
path: root/dev-ruby/color/color-1.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/color/color-1.8.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/color/color-1.8.ebuild')
-rw-r--r--dev-ruby/color/color-1.8.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/color/color-1.8.ebuild b/dev-ruby/color/color-1.8.ebuild
new file mode 100644
index 000000000000..f6c1eb39397c
--- /dev/null
+++ b/dev-ruby/color/color-1.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Colour management with Ruby"
+HOMEPAGE="https://github.com/halostatue/color"
+SRC_URI="https://github.com/halostatue/color/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/minitest-5.0
+ )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e "Dir['test/test_*.rb'].each{|f| require f}" || die
+}