summaryrefslogtreecommitdiff
path: root/dev-ruby/climate_control
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/climate_control
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/climate_control')
-rw-r--r--dev-ruby/climate_control/Manifest3
-rw-r--r--dev-ruby/climate_control/climate_control-0.2.0.ebuild29
-rw-r--r--dev-ruby/climate_control/metadata.xml11
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/climate_control/Manifest b/dev-ruby/climate_control/Manifest
new file mode 100644
index 000000000000..eeacb94ac463
--- /dev/null
+++ b/dev-ruby/climate_control/Manifest
@@ -0,0 +1,3 @@
+DIST climate_control-0.2.0.gem 9728 BLAKE2B 9868eef8836189d7567d8fd8f5dade874ed4baef883f38b2d6148bde4f1e24544f31fae75ff7bcec4dc685c1fdd23d5164817460eeaf151d8eb105e023bbd741 SHA512 c264d731fb02c7a15932d2724bcd54dff91d2370a0b5336444e167e0d39596974c3826db502be7dc1b6d99cdbbc022135822222a5a6cb6b822aa32a0913c1ec9
+EBUILD climate_control-0.2.0.ebuild 657 BLAKE2B d1d686ded8cf2710b0e8cb302bf66e3f53675efc39978c2d4284e0f7d67c462fe280a098e91718289821e5a9d257c946b85922598aabc3057f20fe7788ebe2dd SHA512 3425952c19cdd8d7bfdfa50770e5b6f44aa5d03471af371cd6b7b7b5a3ee413c5fd36e5473fa13d3ffe2382777a12ee942cad06b3c5a2e106a3a8e0ad7de1b9b
+MISC metadata.xml 352 BLAKE2B a7a827d3c582adc7be3ce1b6e979b5325fdc2c6402d404f7072f59c679b2c599f532b530f26777ab9b40bc5ec9f87babda71ec39f685b8b7ce897e3e3cb7078c SHA512 033eff127f4aba2219417b177dbce740027acc4f9e0723e86faca2368ada2cee92e336575cea9d48a255075525c2fc78677f0c48b585f3bdf851372d66517e3d
diff --git a/dev-ruby/climate_control/climate_control-0.2.0.ebuild b/dev-ruby/climate_control/climate_control-0.2.0.ebuild
new file mode 100644
index 000000000000..1c6e46d2953e
--- /dev/null
+++ b/dev-ruby/climate_control/climate_control-0.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="NEWS README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Easily manage your environment"
+HOMEPAGE="https://github.com/thoughtbot/climate_control"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid dependencies on simplecov and git.
+ sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+ sed -i -e 's/git ls-files/echo ""/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
diff --git a/dev-ruby/climate_control/metadata.xml b/dev-ruby/climate_control/metadata.xml
new file mode 100644
index 000000000000..c739d2821a3b
--- /dev/null
+++ b/dev-ruby/climate_control/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">thoughtbot/climate_control</remote-id>
+ </upstream>
+</pkgmetadata>