summaryrefslogtreecommitdiff
path: root/dev-ruby/classifier-reborn/classifier-reborn-2.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-14 13:40:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-14 13:40:00 +0100
commit3e627c1432765cb6a32877e73f985e8bfb5102ce (patch)
treee4d7919d9e1ca0a54c1a3758c86555d6e9121956 /dev-ruby/classifier-reborn/classifier-reborn-2.3.0.ebuild
parent4a30f472147c2d8642bd558b78fcfce7b6a9c6b9 (diff)
gentoo auto-resync : 14:07:2022 - 13:40:00
Diffstat (limited to 'dev-ruby/classifier-reborn/classifier-reborn-2.3.0.ebuild')
-rw-r--r--dev-ruby/classifier-reborn/classifier-reborn-2.3.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/classifier-reborn/classifier-reborn-2.3.0.ebuild b/dev-ruby/classifier-reborn/classifier-reborn-2.3.0.ebuild
new file mode 100644
index 000000000000..7991fe3b1ef3
--- /dev/null
+++ b/dev-ruby/classifier-reborn/classifier-reborn-2.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+RUBY_FAKEGEM_GEMSPEC="classifier-reborn.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Module to allow Bayesian and other types of classifications"
+HOMEPAGE="https://github.com/jekyll/classifier-reborn"
+SRC_URI="https://github.com/jekyll/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="gsl test"
+
+ruby_add_rdepend "
+ >=dev-ruby/fast-stemmer-1.0.0
+ >=dev-ruby/matrix-0.4:0
+ gsl? ( dev-ruby/rb-gsl )"
+ruby_add_bdepend "test? ( dev-ruby/redis )"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ if use !gsl; then
+ sed -e 's/$GSL = true/$GSL = false/'\
+ -e 's/vector_serialize/vector/'\
+ -i lib/${PN}/lsi.rb || die
+ fi
+
+ sed -i -e '/reporters/I s:^:#:' -e '/pry/ s:^:#:' test/test_helper.rb || die
+}