summaryrefslogtreecommitdiff
path: root/dev-ruby/certificate_authority/certificate_authority-0.1.6-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/certificate_authority/certificate_authority-0.1.6-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/certificate_authority/certificate_authority-0.1.6-r2.ebuild')
-rw-r--r--dev-ruby/certificate_authority/certificate_authority-0.1.6-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/certificate_authority/certificate_authority-0.1.6-r2.ebuild b/dev-ruby/certificate_authority/certificate_authority-0.1.6-r2.ebuild
new file mode 100644
index 000000000000..b7f8c502f859
--- /dev/null
+++ b/dev-ruby/certificate_authority/certificate_authority-0.1.6-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Managing the core functions outlined in RFC-3280 for PKI"
+HOMEPAGE="https://github.com/cchandler/certificate_authority"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activemodel-3.0.6:*"
+
+all_ruby_prepare() {
+ # Avoid dependency on dev-libs/engine_pkcs11 that will be hard to
+ # make work on different arches due to hardwired load paths in
+ # specs.
+ rm -f spec/units/pkcs11_key_material_spec.rb || die
+}