summaryrefslogtreecommitdiff
path: root/dev-ruby/certificate_authority/certificate_authority-0.1.6-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/certificate_authority/certificate_authority-0.1.6-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/certificate_authority/certificate_authority-0.1.6-r2.ebuild')
-rw-r--r--dev-ruby/certificate_authority/certificate_authority-0.1.6-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/certificate_authority/certificate_authority-0.1.6-r2.ebuild b/dev-ruby/certificate_authority/certificate_authority-0.1.6-r2.ebuild
new file mode 100644
index 000000000000..037269cd4b8c
--- /dev/null
+++ b/dev-ruby/certificate_authority/certificate_authority-0.1.6-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Managing the core functions outlined in RFC-3280 for PKI"
+HOMEPAGE="https://github.com/cchandler/certificate_authority"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activemodel-3.0.6:*"
+
+all_ruby_prepare() {
+ # Avoid dependency on dev-libs/engine_pkcs11 that will be hard to
+ # make work on different arches due to hardwired load paths in
+ # specs.
+ rm -f spec/units/pkcs11_key_material_spec.rb || die
+}