summaryrefslogtreecommitdiff
path: root/dev-ruby/celluloid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/celluloid
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/celluloid')
-rw-r--r--dev-ruby/celluloid/Manifest3
-rw-r--r--dev-ruby/celluloid/celluloid-0.17.3.ebuild52
-rw-r--r--dev-ruby/celluloid/metadata.xml11
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-ruby/celluloid/Manifest b/dev-ruby/celluloid/Manifest
new file mode 100644
index 000000000000..417c09c1e0a4
--- /dev/null
+++ b/dev-ruby/celluloid/Manifest
@@ -0,0 +1,3 @@
+DIST celluloid-0.17.3.gem 61952 BLAKE2B 5b64b67dea84261706acaf2612c23cb0b82d6af7fe0eece9d9e17e5d948d83a81b0de7598a1709fb5e1073f3632c7df6d6730c4797e0a4da593795b85c3bf9e1 SHA512 bb5005452ef7a2da1fb6b6515a6ad9df992dfd043caa605d1282a24b874c1f0798da0d19ee00f434486f9ef2c9467b1d6d2cadaa7883db98b885eeb842f1b94c
+EBUILD celluloid-0.17.3.ebuild 1362 BLAKE2B e7e598970366e98ef310f219650f12d35e4c90b7544ebb2a18fa9d6b44c9c139473fbd45370097130dd9d15694286114c269fbfc54e93fc29d4485ba764bd309 SHA512 0c142ee124f005db429dc76f4177ddb808237edb59c2491b8ba7dac0d1033ca5b74ff91fbf218d994ec90c6f915243da8fdb92b07ad67b1dba64fa363ac75887
+MISC metadata.xml 345 BLAKE2B 57803cd94baa4d58e4c4c418834347d84a4e8bd5b4ae5019dd71797ace22f508b601bbe62221df4a2fab04eff1fa1aa43d78d98462d189ba13b9bcdf70375f44 SHA512 e07f38e8feadf085f1adeb737ff56aeb9cc4c79a3b7702f9c018544bebcc14646be394aa32ff5502c37ef0fb8968707b7f8d9a6fdaeff23cac5b71fabae46aa8
diff --git a/dev-ruby/celluloid/celluloid-0.17.3.ebuild b/dev-ruby/celluloid/celluloid-0.17.3.ebuild
new file mode 100644
index 000000000000..7e879b85be7e
--- /dev/null
+++ b/dev-ruby/celluloid/celluloid-0.17.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+# Needed by packages writing specs for celluloid
+RUBY_FAKEGEM_EXTRAINSTALL="spec"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a simple and natural way to build fault-tolerant concurrent programs"
+HOMEPAGE="https://github.com/celluloid/celluloid"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+ruby_add_rdepend "
+ dev-ruby/celluloid-essentials
+ dev-ruby/celluloid-extras
+ dev-ruby/celluloid-fsm
+ dev-ruby/celluloid-pool
+ dev-ruby/celluloid-supervision
+ >=dev-ruby/timers-4.1.1"
+
+ruby_add_bdepend "test? (
+ dev-ruby/dotenv
+ dev-ruby/nenv
+ dev-ruby/rspec-retry
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' -e '/coveralls/I s:^:#:' spec/spec_helper.rb || die
+
+ sed -i -e '1irequire "spec_helper"' spec/celluloid/actor/system_spec.rb || die
+
+ sed -i -e '1irequire "pathname"' spec/spec_helper.rb || die
+ mkdir log || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby24)
+ sed -i -e '/String expected, but Fixnum received/ s/Fixnum/Integer/' spec/shared/actor_examples.rb || die
+ ;;
+ esac
+}
diff --git a/dev-ruby/celluloid/metadata.xml b/dev-ruby/celluloid/metadata.xml
new file mode 100644
index 000000000000..8a1a7aed35b3
--- /dev/null
+++ b/dev-ruby/celluloid/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">celluloid/celluloid</remote-id>
+ </upstream>
+</pkgmetadata>