summaryrefslogtreecommitdiff
path: root/dev-ruby/celluloid-io
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/celluloid-io
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/celluloid-io')
-rw-r--r--dev-ruby/celluloid-io/Manifest3
-rw-r--r--dev-ruby/celluloid-io/celluloid-io-0.17.3.ebuild40
-rw-r--r--dev-ruby/celluloid-io/metadata.xml11
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-ruby/celluloid-io/Manifest b/dev-ruby/celluloid-io/Manifest
new file mode 100644
index 000000000000..c36a44ddc93d
--- /dev/null
+++ b/dev-ruby/celluloid-io/Manifest
@@ -0,0 +1,3 @@
+DIST celluloid-io-0.17.3.gem 57856 BLAKE2B 6b2368c9e51a91ba1d7707389f173c1070e2d0a81698538af5240e3798509fe8e3495c2abea83b8c9f49148d3cce59a38823f2a47d7b92da395e78ad71506f8b SHA512 8b1552549c5aad59bf3789518ea2fa6833a4d3b7213cf70d941face215382a68b3d9d2d57e76b2bd7c478fe0e2690b19984d210b806bf1f67f159fd2bdf6b8ac
+EBUILD celluloid-io-0.17.3.ebuild 1111 BLAKE2B 0a12a4bce09694dae80caa4f215479a87a6d2b607cf09ebbde689b412982826b36232d38ef6ea7256e0293c3ab6ca6dfabb74798fb839203779bce24ea19729c SHA512 d00966a5c50e993145c7882c2d85674ed7b923ac9e1522880673a0435980f69a5551dfe0fa8a433162dba5739a62e815e9467df1e79b80756dafec33dcc518d2
+MISC metadata.xml 348 BLAKE2B 82aa98d484afd7116f7d2079ff5358bd3af36987427c49ab3c525325371ff7c8993ce49f7c1dbecd5f12d763972a84358f13523599a929b4406c51e19e13d14d SHA512 b351fe17cb7e9f63c2033e958bf2c6f37dbcae42cd59b76f7c979b42eaf3f35d79e6e82ad2e3bc4cdb2fb7e4410062acadfdfe44a5e767077a223c198bcbd2b8
diff --git a/dev-ruby/celluloid-io/celluloid-io-0.17.3.ebuild b/dev-ruby/celluloid-io/celluloid-io-0.17.3.ebuild
new file mode 100644
index 000000000000..5703464d9361
--- /dev/null
+++ b/dev-ruby/celluloid-io/celluloid-io-0.17.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Evented IO for Celluloid actors"
+HOMEPAGE="https://github.com/celluloid/celluloid-io"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+ruby_add_rdepend ">=dev-ruby/celluloid-0.17.3
+ >=dev-ruby/nio4r-1.2.1:*
+ >=dev-ruby/timers-4.1.1"
+
+ruby_add_bdepend " test? (
+ dev-ruby/dotenv
+ dev-ruby/nenv
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '/[Cc]overalls/ s:^:#:' \
+ -e '2irequire "pathname"; require "fileutils"' spec/spec_helper.rb || die
+
+ # Avoid DNS tests. They either assume localhost is 127.0.0.1 or
+ # require network access.
+ rm spec/celluloid/io/dns_resolver_spec.rb || die
+
+ # Make sure test logs end up in the right place
+ sed -i -e 's:log/test.log:'${T}'/test.log:' .env-dev || die
+}
diff --git a/dev-ruby/celluloid-io/metadata.xml b/dev-ruby/celluloid-io/metadata.xml
new file mode 100644
index 000000000000..ddf682e8b949
--- /dev/null
+++ b/dev-ruby/celluloid-io/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">celluloid/celluloid-io</remote-id>
+ </upstream>
+</pkgmetadata>