summaryrefslogtreecommitdiff
path: root/dev-ruby/bunny/bunny-2.17.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-ruby/bunny/bunny-2.17.0.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-ruby/bunny/bunny-2.17.0.ebuild')
-rw-r--r--dev-ruby/bunny/bunny-2.17.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/bunny/bunny-2.17.0.ebuild b/dev-ruby/bunny/bunny-2.17.0.ebuild
new file mode 100644
index 000000000000..7bc6776b0c7e
--- /dev/null
+++ b/dev-ruby/bunny/bunny-2.17.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+# Tests require a live AMQP server.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Another synchronous Ruby AMQP client"
+HOMEPAGE="https://github.com/celldee/bunny"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/amq-protocol-2.3.1:2"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc -r examples
+}